summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@outlook.com>2021-02-09 14:01:13 +0100
committerTiger Wang <ziwei.tiger@outlook.com>2021-02-10 11:30:32 +0100
commit86cfb3821150d24cd60e5501720779696379643a (patch)
treeb84026063826f4d21e4c9cfe0a0b3f9b5a255c3b /CMakeLists.txt
parentCompositeChat: use variants (diff)
downloadcuberite-86cfb3821150d24cd60e5501720779696379643a.tar
cuberite-86cfb3821150d24cd60e5501720779696379643a.tar.gz
cuberite-86cfb3821150d24cd60e5501720779696379643a.tar.bz2
cuberite-86cfb3821150d24cd60e5501720779696379643a.tar.lz
cuberite-86cfb3821150d24cd60e5501720779696379643a.tar.xz
cuberite-86cfb3821150d24cd60e5501720779696379643a.tar.zst
cuberite-86cfb3821150d24cd60e5501720779696379643a.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70f25184a..f1204b8bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,8 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# File failed to follow NHS guidelines on handwashing and has not maintained good hygiene
set_source_files_properties("${PROJECT_SOURCE_DIR}/src/IniFile.cpp" PROPERTIES COMPILE_OPTIONS -Wno-header-hygiene)
+elseif (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ set_source_files_properties("${PROJECT_SOURCE_DIR}/src/Bindings/Bindings.cpp" PROPERTIES COMPILE_OPTIONS -w)
endif()
if(${BUILD_TOOLS})