summaryrefslogtreecommitdiffstats
path: root/tests/BlockTypeRegistry/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@outlook.com>2020-09-08 10:46:16 +0200
committerTiger Wang <ziwei.tiger@outlook.com>2020-12-21 01:11:34 +0100
commit742e27ad2f037205285e475be487ec9ed874ca91 (patch)
tree3218d3c2791e823c88a294ba7fdb10035c8fbb9b /tests/BlockTypeRegistry/CMakeLists.txt
parentEnable LOS checks for Hostile Mobs. (diff)
downloadcuberite-742e27ad2f037205285e475be487ec9ed874ca91.tar
cuberite-742e27ad2f037205285e475be487ec9ed874ca91.tar.gz
cuberite-742e27ad2f037205285e475be487ec9ed874ca91.tar.bz2
cuberite-742e27ad2f037205285e475be487ec9ed874ca91.tar.lz
cuberite-742e27ad2f037205285e475be487ec9ed874ca91.tar.xz
cuberite-742e27ad2f037205285e475be487ec9ed874ca91.tar.zst
cuberite-742e27ad2f037205285e475be487ec9ed874ca91.zip
Diffstat (limited to '')
-rw-r--r--tests/BlockTypeRegistry/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/tests/BlockTypeRegistry/CMakeLists.txt b/tests/BlockTypeRegistry/CMakeLists.txt
index b9036ffdf..e81d5ff38 100644
--- a/tests/BlockTypeRegistry/CMakeLists.txt
+++ b/tests/BlockTypeRegistry/CMakeLists.txt
@@ -7,7 +7,7 @@ include_directories(${PROJECT_SOURCE_DIR}/src/)
add_executable(BlockStateTest
BlockStateTest.cpp
../TestHelpers.h
- ${PROJECT_SOURCE_DIR}/src/BlockState.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockState.cpp
${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
)
@@ -16,8 +16,8 @@ target_link_libraries(BlockStateTest fmt::fmt)
add_executable(BlockTypePaletteTest
BlockTypePaletteTest.cpp
../TestHelpers.h
- ${PROJECT_SOURCE_DIR}/src/BlockState.cpp
- ${PROJECT_SOURCE_DIR}/src/BlockTypePalette.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockState.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockTypePalette.cpp
${PROJECT_SOURCE_DIR}/src/JsonUtils.cpp
${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
@@ -29,7 +29,7 @@ target_link_libraries(BlockTypePaletteTest fmt::fmt jsoncpp_lib)
add_executable(BlockTypeRegistryTest
BlockTypeRegistryTest.cpp
../TestHelpers.h
- ${PROJECT_SOURCE_DIR}/src/BlockTypeRegistry.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockTypeRegistry.cpp
${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
)
@@ -39,9 +39,9 @@ target_link_libraries(BlockTypeRegistryTest fmt::fmt Threads::Threads)
add_executable(PalettedBlockAreaTest
PalettedBlockAreaTest.cpp
../TestHelpers.h
- ${PROJECT_SOURCE_DIR}/src/BlockState.cpp
- ${PROJECT_SOURCE_DIR}/src/BlockTypeRegistry.cpp
- ${PROJECT_SOURCE_DIR}/src/BlockTypePalette.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockState.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockTypeRegistry.cpp
+ ${PROJECT_SOURCE_DIR}/src/Bindings/BlockTypePalette.cpp
${PROJECT_SOURCE_DIR}/src/Cuboid.cpp
${PROJECT_SOURCE_DIR}/src/JsonUtils.cpp
${PROJECT_SOURCE_DIR}/src/PalettedBlockArea.cpp