summaryrefslogtreecommitdiffstats
path: root/Tools/MCADefrag/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/MCADefrag/CMakeLists.txt')
-rw-r--r--Tools/MCADefrag/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/Tools/MCADefrag/CMakeLists.txt b/Tools/MCADefrag/CMakeLists.txt
index 700310edc..9d600d3ec 100644
--- a/Tools/MCADefrag/CMakeLists.txt
+++ b/Tools/MCADefrag/CMakeLists.txt
@@ -11,8 +11,13 @@ set_flags()
set_lib_flags()
enable_profile()
-
-
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_flags_cxx("-Wno-error=sign-conversion -Wno-error=conversion -Wno-error=shorten-64-to-32")
+ add_flags_cxx("-Wno-error=old-style-cast")
+ if ("${CLANG_VERSION}" VERSION_GREATER 3.5)
+ add_flags_cxx("-Wno-error=keyword-macro")
+ endif()
+endif()
# Set include paths to the used libraries:
include_directories("../../lib")