summaryrefslogtreecommitdiffstats
path: root/lib/tolua++/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tolua++/CMakeLists.txt')
-rw-r--r--lib/tolua++/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/lib/tolua++/CMakeLists.txt b/lib/tolua++/CMakeLists.txt
new file mode 100644
index 000000000..239232c38
--- /dev/null
+++ b/lib/tolua++/CMakeLists.txt
@@ -0,0 +1,25 @@
+
+cmake_minimum_required (VERSION 2.6)
+project (tolua++)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
+include_directories ("${PROJECT_SOURCE_DIR}/include/")
+include_directories ("${PROJECT_SOURCE_DIR}/../")
+
+file(GLOB LIB_SOURCE
+ "src/lib/*.c"
+)
+
+file(GLOB BIN_SOURCE
+ "src/bin/*.c"
+)
+
+add_executable(tolua ${BIN_SOURCE})
+add_library(tolualib ${LIB_SOURCE})
+
+#m is the standard math librarys
+if(UNIX)
+target_link_libraries(tolua m)
+endif()
+
+target_link_libraries(tolua lua tolualib)