summaryrefslogtreecommitdiffstats
path: root/src/Generating/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/Generating/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Generating/CMakeLists.txt b/src/Generating/CMakeLists.txt
index b3960914c..9063abd97 100644
--- a/src/Generating/CMakeLists.txt
+++ b/src/Generating/CMakeLists.txt
@@ -58,6 +58,8 @@ SET (HDRS
UnderwaterBaseGen.h
VillageGen.h)
-add_library(Generating ${SRCS} ${HDRS})
+if(NOT MSVC)
+ add_library(Generating ${SRCS} ${HDRS})
-target_link_libraries(Generating OSSupport iniFile Blocks)
+ target_link_libraries(Generating OSSupport iniFile Blocks)
+endif()