summaryrefslogtreecommitdiffstats
path: root/tests/ChunkBuffer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ChunkBuffer/CMakeLists.txt')
-rw-r--r--tests/ChunkBuffer/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/ChunkBuffer/CMakeLists.txt b/tests/ChunkBuffer/CMakeLists.txt
index 33722f785..08d01d1a0 100644
--- a/tests/ChunkBuffer/CMakeLists.txt
+++ b/tests/ChunkBuffer/CMakeLists.txt
@@ -2,9 +2,15 @@ cmake_minimum_required (VERSION 2.6)
enable_testing()
+include_directories(${CMAKE_SOURCE_DIR}/src/)
+
add_library(ChunkBuffer ${CMAKE_SOURCE_DIR}/src/ChunkBuffer.cpp)
add_executable(creatable-exe creatable.cpp)
target_link_libraries(creatable-exe ChunkBuffer)
add_test(NAME creatable-test COMMAND creatable-exe)
+
+add_executable(coordinates-exe Coordinates.cpp)
+target_link_libraries(coordinates-exe ChunkBuffer)
+add_test(NAME coordinates-test COMMAND coordinates-exe)