summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 247a48b..2577ca0 100644
--- a/setup.py
+++ b/setup.py
@@ -29,6 +29,17 @@ setup(
],
extras_require = {
'test': ['abseil-py'],
+ # These are all the drivers' dependencies. Optional dependencies are
+ # listed as mandatory for the feature.
+ 'otultra2': ['pyserial'],
+ 'otultraeasy': ['pyserial'],
+ 'otverio2015': ['python-scsi'],
+ 'fsinsulinx': ['hidapi'],
+ 'fslibre': ['hidapi'],
+ 'fsoptium': ['hidapi'],
+ 'fsprecisionneo': ['hidapi'],
+ 'accucheck_reports': [],
+ 'sdcodefree': ['pyserial'],
},
entry_points = {
'console_scripts': [