summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorostix360 <vicrobin1001@gmail.com>2023-06-26 09:28:01 +0200
committerostix360 <vicrobin1001@gmail.com>2023-06-26 09:28:01 +0200
commit2b21cda41aa813a3b1b7fb06929675e7e4e05cfd (patch)
treefa32d897402bbfa8b004ff978f9e01af0a443505 /pyproject.toml
parentUpdate instructions (diff)
downloadgpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.tar
gpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.tar.gz
gpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.tar.bz2
gpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.tar.lz
gpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.tar.xz
gpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.tar.zst
gpt4free-2b21cda41aa813a3b1b7fb06929675e7e4e05cfd.zip
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..6f170632
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,20 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "gpt4free"
+version = "0.2.0"
+description = ""
+authors = []
+license = { text = "GPL-3.0" }
+readme = "README.md"
+requires-python = ">=3.10"
+dynamic = ["dependencies"]
+
+[tool.setuptools.packages.find]
+exclude = ["**/*.txt", "/.v1/*"]
+
+
+[tool.setuptools.dynamic]
+dependencies = {file = ["requirements.txt"]} \ No newline at end of file