diff options
author | Tekky <98614666+xtekky@users.noreply.github.com> | 2024-01-12 12:51:25 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2024-01-12 12:51:25 +0100 |
commit | 4b5fffc26599b7933c9813f2f7d860adac4e1014 (patch) | |
tree | 3e3a7bc5183ff08fb5a176efeb61264c87c49ece /setup.py | |
parent | ~ | g4f v-0.2.0.1 (diff) | |
parent | Merge branch 'main' into pypi (diff) | |
download | gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.tar gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.tar.gz gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.tar.bz2 gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.tar.lz gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.tar.xz gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.tar.zst gpt4free-4b5fffc26599b7933c9813f2f7d860adac4e1014.zip |
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 39 |
1 files changed, 34 insertions, 5 deletions
@@ -8,10 +8,39 @@ here = os.path.abspath(os.path.dirname(__file__)) with codecs.open(os.path.join(here, 'README.md'), encoding='utf-8') as fh: long_description = '\n' + fh.read() -with open('requirements.txt') as f: - required = f.read().splitlines() +install_requires = [ + "requests", + "pycryptodome", + "curl_cffi>=0.5.10", + "aiohttp", + "certifi", + "browser_cookie3", + "websockets", + "js2py", + "typing-extensions", + "PyExecJS", + "duckduckgo-search", + "nest_asyncio", + "waitress", + "werkzeug", + "loguru", + "pillow", + "platformdirs", + "numpy", + "asgiref", + "fastapi", + "uvicorn", + "flask", + "py-arkose-generator", + "asyncstdlib", + "async-property", + "undetected-chromedriver", + "asyncstdlib", + "async_property", + "brotli", + "beautifulsoup4", +] -VERSION = '0.2.0.1' DESCRIPTION = ( 'The official gpt4free repository | various collection of powerful language models' ) @@ -19,7 +48,7 @@ DESCRIPTION = ( # Setting up setup( name='g4f', - version=VERSION, + version=os.environ.get("G4F_VERSION"), author='Tekky', author_email='<support@g4f.ai>', description=DESCRIPTION, @@ -30,7 +59,7 @@ setup( 'g4f': ['g4f/interference/*', 'g4f/gui/client/*', 'g4f/gui/server/*', 'g4f/Provider/npm/*'] }, include_package_data=True, - install_requires=required, + install_requires=install_requires, entry_points={ 'console_scripts': ['g4f=g4f.cli:main'], }, |