summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info')
-rw-r--r--venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/INSTALLER1
-rw-r--r--venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/LICENSE21
-rw-r--r--venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/METADATA50
-rw-r--r--venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/RECORD7
-rw-r--r--venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/WHEEL4
5 files changed, 83 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/INSTALLER b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/INSTALLER
new file mode 100644
index 00000000..a1b589e3
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/INSTALLER
@@ -0,0 +1 @@
+pip
diff --git a/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/LICENSE b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/LICENSE
new file mode 100644
index 00000000..11be2a75
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 Thomas Kluyver and contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/METADATA b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/METADATA
new file mode 100644
index 00000000..f561746c
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/METADATA
@@ -0,0 +1,50 @@
+Metadata-Version: 2.1
+Name: entrypoints
+Version: 0.4
+Summary: Discover and load entry points from installed packages.
+Home-page: https://github.com/takluyver/entrypoints
+Author: Thomas Kluyver
+Author-email: thomas@kluyver.me.uk
+Requires-Python: >=3.6
+Description-Content-Type: text/x-rst
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Programming Language :: Python :: 3
+Project-URL: Documentation, https://entrypoints.readthedocs.io/en/latest/
+
+**This package is in maintenance-only mode.** New code should use the
+`importlib.metadata module <https://docs.python.org/3/library/importlib.metadata.html>`_
+in the Python standard library to find and load entry points.
+
+Entry points are a way for Python packages to advertise objects with some
+common interface. The most common examples are ``console_scripts`` entry points,
+which define shell commands by identifying a Python function to run.
+
+*Groups* of entry points, such as ``console_scripts``, point to objects with
+similar interfaces. An application might use a group to find its plugins, or
+multiple groups if it has different kinds of plugins.
+
+The **entrypoints** module contains functions to find and load entry points.
+You can install it from PyPI with ``pip install entrypoints``.
+
+To advertise entry points when distributing a package, see
+`entry_points in the Python Packaging User Guide
+<https://packaging.python.org/guides/distributing-packages-using-setuptools/#entry-points>`_.
+
+The ``pkg_resources`` module distributed with ``setuptools`` provides a way to
+discover entrypoints as well, but it contains other functionality unrelated to
+entrypoint discovery, and it does a lot of work at import time. Merely
+*importing* ``pkg_resources`` causes it to scan the files of all installed
+packages. Thus, in environments where a large number of packages are installed,
+importing ``pkg_resources`` can be very slow (several seconds).
+
+By contrast, ``entrypoints`` is focused solely on entrypoint discovery and it
+is faster. Importing ``entrypoints`` does not scan anything, and getting a
+given entrypoint group performs a more focused scan.
+
+When there are multiple versions of the same distribution in different
+directories on ``sys.path``, ``entrypoints`` follows the rule that the first
+one wins. In most cases, this follows the logic of imports. Similarly,
+Entrypoints relies on ``pip`` to ensure that only one ``.dist-info`` or
+``.egg-info`` directory exists for each installed package. There is no reliable
+way to pick which of several `.dist-info` folders accurately relates to the
+importable modules.
diff --git a/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/RECORD b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/RECORD
new file mode 100644
index 00000000..d507f85f
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/RECORD
@@ -0,0 +1,7 @@
+__pycache__/entrypoints.cpython-39.pyc,,
+entrypoints-0.4.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
+entrypoints-0.4.dist-info/LICENSE,sha256=3l_Nc0nN85mwcHoqAkgzxHBHQ2UBM8ctbw_3VhoDqEg,1098
+entrypoints-0.4.dist-info/METADATA,sha256=lSxVz4n_TbBgF_iWUL4ckck2MbkomDWg9MPiiees0mc,2589
+entrypoints-0.4.dist-info/RECORD,,
+entrypoints-0.4.dist-info/WHEEL,sha256=jPMR_Dzkc4X4icQtmz81lnNY_kAsfog7ry7qoRvYLXw,81
+entrypoints.py,sha256=H958LBmFrgIBoUklvcFiqEf1jV0kxVIPENNGE1QaUd0,8264
diff --git a/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/WHEEL b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/WHEEL
new file mode 100644
index 00000000..c727d148
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/entrypoints-0.4.dist-info/WHEEL
@@ -0,0 +1,4 @@
+Wheel-Version: 1.0
+Generator: flit 3.6.0
+Root-Is-Purelib: true
+Tag: py3-none-any