summaryrefslogtreecommitdiffstats
path: root/heimdall-frontend/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Dobell <benjamin.dobell+git@glassechidna.com.au>2015-02-18 19:08:26 +0100
committerBenjamin Dobell <benjamin.dobell+git@glassechidna.com.au>2015-02-18 19:22:04 +0100
commit67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa (patch)
tree006bc568c36bb43a4dbaed17c8ffb0d0dbdcb12f /heimdall-frontend/CMakeLists.txt
parentRemoved autotools and VS files, and standardised source dir naming (diff)
downloadHeimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.tar
Heimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.tar.gz
Heimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.tar.bz2
Heimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.tar.lz
Heimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.tar.xz
Heimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.tar.zst
Heimdall-67c17cc48bc3a2914d8e6ecb39ec1fb54b4806aa.zip
Diffstat (limited to 'heimdall-frontend/CMakeLists.txt')
-rw-r--r--heimdall-frontend/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/heimdall-frontend/CMakeLists.txt b/heimdall-frontend/CMakeLists.txt
index 76dac2e..95889b3 100644
--- a/heimdall-frontend/CMakeLists.txt
+++ b/heimdall-frontend/CMakeLists.txt
@@ -12,7 +12,10 @@ find_package(Qt5Widgets REQUIRED)
find_package(ZLIB REQUIRED)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
-set(CMAKE_EXE_LINKER_FLAGS "-static-libgcc -static-libstdc++ -static")
+
+if(MINGW)
+ set(CMAKE_EXE_LINKER_FLAGS "-static-libgcc -static-libstdc++ -static")
+endif(MINGW)
include_directories(${LIBPIT_INCLUDE_DIRS})
@@ -33,6 +36,7 @@ qt5_add_resources(HEIMDALL_FRONTEND_RESOURCES
mainwindow.qrc)
add_executable(heimdall-frontend WIN32
+ MACOSX_BUNDLE
${HEIMDALL_FRONTEND_SOURCE_FILES}
${HEIMDALL_FRONTEND_FORMS}
${HEIMDALL_FRONTEND_RESOURCES})