summaryrefslogtreecommitdiffstats
path: root/heimdall-frontend/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Dobell <benjamin.dobell+git@glassechidna.com.au>2015-03-11 18:01:41 +0100
committerBenjamin Dobell <benjamin.dobell+git@glassechidna.com.au>2015-03-11 18:09:40 +0100
commit7c6ee7f1a24faeafc793414e877bf014743d9cfe (patch)
tree805b7839234bae16eeac75f33c471e7ee22f0c0f /heimdall-frontend/CMakeLists.txt
parentLots of Frontend refactoring with a few bug fixes (diff)
downloadHeimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.tar
Heimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.tar.gz
Heimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.tar.bz2
Heimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.tar.lz
Heimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.tar.xz
Heimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.tar.zst
Heimdall-7c6ee7f1a24faeafc793414e877bf014743d9cfe.zip
Diffstat (limited to 'heimdall-frontend/CMakeLists.txt')
-rw-r--r--heimdall-frontend/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/heimdall-frontend/CMakeLists.txt b/heimdall-frontend/CMakeLists.txt
index da572cb..a8f4baa 100644
--- a/heimdall-frontend/CMakeLists.txt
+++ b/heimdall-frontend/CMakeLists.txt
@@ -23,9 +23,12 @@ if(ENABLE_QML_DEBUGGING)
add_definitions(-DENABLE_QML_DEBUGGING)
endif(ENABLE_QML_DEBUGGING)
-include_directories(${LIBPIT_INCLUDE_DIRS})
+include_directories(${LIBPIT_INCLUDE_DIRS}
+ source/qml/bindings
+ source)
set(HEIMDALL_FRONTEND_SOURCE_FILES
+ source/qml/bindings/Firmware.cpp
source/aboutform.cpp
source/Alerts.cpp
source/FirmwareInfo.cpp
@@ -36,6 +39,7 @@ set(HEIMDALL_FRONTEND_SOURCE_FILES
source/Packaging.cpp)
set(HEIMDALL_FRONTEND_QML_FILES
+ source/qml/ArrayExtensions.js
source/qml/DropFiles.qml
source/qml/DropFilesForm.qml
source/qml/FileUtils.js