summaryrefslogtreecommitdiffstats
path: root/libusb-1.0/examples/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dobell <benjamin.dobell+github@glassechidna.com.au>2010-12-04 14:25:04 +0100
committerBenjamin Dobell <benjamin.dobell+github@glassechidna.com.au>2010-12-04 14:25:04 +0100
commit46f2c1134d276944fb74584a61d90cc363aee7eb (patch)
tree6fa14b7ef509a3fb84305dec013dd24bcae6c17d /libusb-1.0/examples/Makefile.am
parentAddresses: (diff)
downloadHeimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.tar
Heimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.tar.gz
Heimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.tar.bz2
Heimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.tar.lz
Heimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.tar.xz
Heimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.tar.zst
Heimdall-46f2c1134d276944fb74584a61d90cc363aee7eb.zip
Diffstat (limited to 'libusb-1.0/examples/Makefile.am')
-rw-r--r--libusb-1.0/examples/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/libusb-1.0/examples/Makefile.am b/libusb-1.0/examples/Makefile.am
new file mode 100644
index 0000000..e8a4516
--- /dev/null
+++ b/libusb-1.0/examples/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES = -I$(top_srcdir)/libusb
+noinst_PROGRAMS = xusb lsusb
+
+lsusb_SOURCES = lsusb.c
+lsusb_LDADD = ../libusb/libusb-1.0.la -lusb-1.0
+
+xusb_SOURCES = xusb.c
+xusb_LDADD = ../libusb/libusb-1.0.la -lusb-1.0
+
+if HAVE_SIGACTION
+dpfp_SOURCES = dpfp.c
+dpfp_LDADD = ../libusb/libusb-1.0.la -lusb-1.0
+noinst_PROGRAMS += dpfp
+endif
+
+if THREADS_POSIX
+if HAVE_SIGACTION
+dpfp_threaded_SOURCES = dpfp_threaded.c
+dpfp_threaded_CFLAGS = $(THREAD_CFLAGS) $(AM_CFLAGS)
+dpfp_threaded_LDADD = ../libusb/libusb-1.0.la -lusb-1.0
+noinst_PROGRAMS += dpfp_threaded
+endif
+endif