summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2016-03-01 16:58:43 +0100
committerMattes D <github@xoft.cz>2016-03-01 16:58:43 +0100
commit7cc8f8dd2213cade66633d196f579895385a869a (patch)
tree83219a6eaf87a2050c10662fb8caa5d1514a6af4 /CMakeLists.txt
parentMerge pull request #3057 from tonibm19/master (diff)
parentHTTP: Fixed typos and bad leftovers. (diff)
downloadcuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.gz
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.bz2
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.lz
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.xz
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.zst
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3234e93d7..2b5abb362 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,6 +127,9 @@ if(${SELF_TEST})
add_definitions(-DSELF_TEST)
endif()
+# Build all dependent libraries as static:
+SET(CMAKE_BUILD_STATIC_LIBRARIES ON)
+
@@ -263,6 +266,7 @@ if (MSVC)
if (${SELF_TEST})
set_target_properties(
Network
+ HTTP
PROPERTIES FOLDER Lib
)
set_target_properties(
@@ -274,6 +278,7 @@ if (MSVC)
creatable-exe
EchoServer
Google-exe
+ HTTPMessageParser_file-exe
LoadablePieces
NameLookup
PROPERTIES FOLDER Tests