summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2014-08-01 22:35:12 +0200
committerMattes D <github@xoft.cz>2014-08-01 22:35:12 +0200
commit941a182d8a8a210bb6400cc6b2750a06b5f6c038 (patch)
tree82dfee0f38536020345a820c84ff2c4f01c3213b /CMakeLists.txt
parentMerge pull request #1273 from Howaner/GlobalFixes (diff)
parentMerged branch 'master' into NameToUUID. (diff)
downloadcuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.tar
cuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.tar.gz
cuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.tar.bz2
cuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.tar.lz
cuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.tar.xz
cuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.tar.zst
cuberite-941a182d8a8a210bb6400cc6b2750a06b5f6c038.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6400c1b4..dd9b1e67c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,14 @@ endif()
project (MCServer)
+# Set options for SQLiteCpp, disable all their tests and lints:
+set(SQLITECPP_RUN_CPPLINT OFF CACHE BOOL "Run cpplint.py tool for Google C++ StyleGuide." FORCE)
+set(SQLITECPP_RUN_CPPCHECK OFF CACHE BOOL "Run cppcheck C++ static analysis tool." FORCE)
+set(SQLITECPP_RUN_DOXYGEN OFF CACHE BOOL "Run Doxygen C++ documentation tool." FORCE)
+set(SQLITECPP_BUILD_EXAMPLES OFF CACHE BOOL "Build examples." FORCE)
+set(SQLITECPP_BUILD_TESTS OFF CACHE BOOL "Build and run tests." FORCE)
+set(SQLITECPP_INTERNAL_SQLITE OFF CACHE BOOL "Add the internal SQLite3 source to the project." FORCE)
+
# Include all the libraries:
add_subdirectory(lib/inifile/)
add_subdirectory(lib/jsoncpp/)
@@ -60,9 +68,16 @@ add_subdirectory(lib/zlib/)
add_subdirectory(lib/lua/)
add_subdirectory(lib/tolua++/)
add_subdirectory(lib/sqlite/)
+add_subdirectory(lib/SQLiteCpp/)
add_subdirectory(lib/expat/)
add_subdirectory(lib/luaexpat/)
+# Add proper include directories so that SQLiteCpp can find SQLite3:
+get_property(SQLITECPP_INCLUDES DIRECTORY "lib/SQLiteCpp/" PROPERTY INCLUDE_DIRECTORIES)
+set(SQLITECPP_INCLUDES "${SQLITECPP_INCLUDES}" "${CMAKE_CURRENT_SOURCE_DIR}/lib/sqlite/")
+set_property(DIRECTORY lib/SQLiteCpp/ PROPERTY INCLUDE_DIRECTORIES "${SQLITECPP_INCLUDES}")
+set_property(TARGET SQLiteCpp PROPERTY INCLUDE_DIRECTORIES "${SQLITECPP_INCLUDES}")
+
if (WIN32)
add_subdirectory(lib/luaproxy/)
endif()