summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTycho Bickerstaff <work.tycho@gmail.com>2014-01-02 18:49:55 +0100
committerTycho Bickerstaff <work.tycho@gmail.com>2014-01-02 18:49:55 +0100
commitea6f94f6cb703f29511a844fc9e14567986e73ee (patch)
tree6b9df61798a94c8e9977deb44de148b76a55d331 /CMakeLists.txt
parentadded documentation (diff)
parentMerge remote-tracking branch 'origin/master' (diff)
downloadcuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.tar
cuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.tar.gz
cuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.tar.bz2
cuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.tar.lz
cuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.tar.xz
cuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.tar.zst
cuberite-ea6f94f6cb703f29511a844fc9e14567986e73ee.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67f70142b..451854074 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,11 +112,15 @@ add_subdirectory(lib/expat/)
add_subdirectory(lib/luaexpat/)
add_subdirectory(lib/md5/)
-# Re-add the maximum warning level:
+# Remove disabling the maximum warning level:
+# clang does not like a command line that reads -Wall -Wextra -w -Wall -Wextra and does not output any warnings
# We do not do that for MSVC since MSVC produces an awful lot of warnings for its own STL headers;
# the important warnings will be turned on using #pragma in Globals.h
if (NOT MSVC)
- add_flags("-Wall -Wextra")
+ string(REPLACE "-w" "" CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
+ string(REPLACE "-w" "" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
+ string(REPLACE "-w" "" CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")
+ string(REPLACE "-w" "" CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG}")
endif()
add_subdirectory (src)