summaryrefslogtreecommitdiffstats
path: root/lib/expat/CMakeLists.txt
diff options
context:
space:
mode:
authormadmaxoft <github@xoft.cz>2013-12-27 11:51:08 +0100
committermadmaxoft <github@xoft.cz>2013-12-27 11:51:08 +0100
commit1cf6502be23ff78e07a96b906738c97805120ca0 (patch)
treea3dad40d5fd0556b17e1b95ce80e67e6f24b6fe2 /lib/expat/CMakeLists.txt
parentAdded proper precompiled headers for MSVC. (diff)
downloadcuberite-1cf6502be23ff78e07a96b906738c97805120ca0.tar
cuberite-1cf6502be23ff78e07a96b906738c97805120ca0.tar.gz
cuberite-1cf6502be23ff78e07a96b906738c97805120ca0.tar.bz2
cuberite-1cf6502be23ff78e07a96b906738c97805120ca0.tar.lz
cuberite-1cf6502be23ff78e07a96b906738c97805120ca0.tar.xz
cuberite-1cf6502be23ff78e07a96b906738c97805120ca0.tar.zst
cuberite-1cf6502be23ff78e07a96b906738c97805120ca0.zip
Diffstat (limited to 'lib/expat/CMakeLists.txt')
-rw-r--r--lib/expat/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/expat/CMakeLists.txt b/lib/expat/CMakeLists.txt
index df9e8d57c..667804b9a 100644
--- a/lib/expat/CMakeLists.txt
+++ b/lib/expat/CMakeLists.txt
@@ -2,10 +2,15 @@
cmake_minimum_required (VERSION 2.6)
project (expat)
-include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
-
file(GLOB SOURCE
"*.c"
)
+# add headers to MSVC project files:
+if (WIN32)
+ file(GLOB HEADERS "*.h")
+ set(SOURCE ${SOURCE} ${HEADERS})
+ source_group("Sources" FILES ${SOURCE})
+endif()
+
add_library(expat ${SOURCE})