summaryrefslogtreecommitdiffstats
path: root/src/Bindings/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Laubstein <julianlaubstein@yahoo.de>2015-08-12 17:40:51 +0200
committerJulian Laubstein <julianlaubstein@yahoo.de>2015-08-12 17:40:51 +0200
commitcdcc5fe9a7894af6075865f698e3d014a6f92335 (patch)
treeab1b84a09987f8ebe9d1e8450f36375c0f9bc5db /src/Bindings/CMakeLists.txt
parentMerge pull request #2425 from cuberite/APIDumpNameChange (diff)
parentFix old style casts and implicit conversions (diff)
downloadcuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.tar
cuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.tar.gz
cuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.tar.bz2
cuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.tar.lz
cuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.tar.xz
cuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.tar.zst
cuberite-cdcc5fe9a7894af6075865f698e3d014a6f92335.zip
Diffstat (limited to 'src/Bindings/CMakeLists.txt')
-rw-r--r--src/Bindings/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Bindings/CMakeLists.txt b/src/Bindings/CMakeLists.txt
index edcda273e..673109ffa 100644
--- a/src/Bindings/CMakeLists.txt
+++ b/src/Bindings/CMakeLists.txt
@@ -146,6 +146,7 @@ set_source_files_properties(${BINDING_OUTPUTS} PROPERTIES GENERATED TRUE)
set_source_files_properties(${CMAKE_SOURCE_DIR}/src/Bindings/Bindings.cpp PROPERTIES COMPILE_FLAGS -Wno-error)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set_source_files_properties(${CMAKE_SOURCE_DIR}/src/Bindings/Bindings.cpp PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS} "-Wno-old-style-cast -Wno-missing-prototypes")
set_source_files_properties(LuaWindow.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum")
endif()