summaryrefslogtreecommitdiffstats
path: root/src/Bindings/CMakeLists.txt
diff options
context:
space:
mode:
authorarchshift <admin@archshift.com>2014-07-19 04:25:15 +0200
committerarchshift <admin@archshift.com>2014-07-19 04:53:47 +0200
commit0960e6ae8ffe329ecd78b2f0f433fcb9e817a696 (patch)
tree9f884f685f1ac21deda656ac175376ff2ede5e8c /src/Bindings/CMakeLists.txt
parentCMakeLists: Moved Bindings-specific code to subdir (diff)
downloadcuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.tar
cuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.tar.gz
cuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.tar.bz2
cuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.tar.lz
cuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.tar.xz
cuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.tar.zst
cuberite-0960e6ae8ffe329ecd78b2f0f433fcb9e817a696.zip
Diffstat (limited to 'src/Bindings/CMakeLists.txt')
-rw-r--r--src/Bindings/CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/src/Bindings/CMakeLists.txt b/src/Bindings/CMakeLists.txt
index 723487ff0..4726eea23 100644
--- a/src/Bindings/CMakeLists.txt
+++ b/src/Bindings/CMakeLists.txt
@@ -112,21 +112,7 @@ set(BINDING_DEPENDECIES
../World.h
)
-if (WIN32)
- ADD_CUSTOM_COMMAND(
- OUTPUT ${BINDING_OUTPUTS}
-
- # Copy the Lua DLL into the Bindings folder, so that tolua can run from there:
- COMMAND ${CMAKE_COMMAND} -E copy_if_different ../../MCServer/lua51.dll ./lua51.dll
-
- # Regenerate bindings:
- COMMAND tolua -L virtual_method_hooks.lua -o Bindings.cpp -H Bindings.h AllToLua.pkg
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
-
- # add any new generation dependencies here
- DEPENDS ${BINDING_DEPENDECIES}
- )
-else ()
+if (NOT WIN32)
ADD_CUSTOM_COMMAND(
# add any new generated bindings here
OUTPUT ${BINDING_OUTPUTS}