summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTycho <work.tycho+git@gmail.com>2014-09-10 17:07:00 +0200
committerTycho <work.tycho+git@gmail.com>2014-09-10 17:07:00 +0200
commit27be1799392e89b2b67121ea6febd51c2b9ec4fb (patch)
tree291f4dd8941c94ebec2d17b1605d13fa0f5f4dab /src/CMakeLists.txt
parentMerge pull request #1402 from Masy98/Sounds (diff)
downloadcuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.tar
cuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.tar.gz
cuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.tar.bz2
cuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.tar.lz
cuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.tar.xz
cuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.tar.zst
cuberite-27be1799392e89b2b67121ea6febd51c2b9ec4fb.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2d96662a9..9d0e2cede 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -75,6 +75,7 @@ SET (HDRS
BlockInfo.h
BlockTracer.h
BoundingBox.h
+ BuildInfo.h.cmake
ByteBuffer.h
ChatColor.h
Chunk.h
@@ -140,6 +141,8 @@ include_directories(".")
include_directories ("${CMAKE_CURRENT_SOURCE_DIR}/../lib/sqlite")
include_directories ("${CMAKE_CURRENT_SOURCE_DIR}/../lib/SQLiteCpp/include")
+configure_file("BuildInfo.h.cmake" "${CMAKE_CURRENT_SOURCE_DIR}/BuildInfo.h")
+
if (NOT MSVC)
# Bindings need to reference other folders, so they are done here instead
# lib dependencies are not included