summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authormadmaxoft <github@xoft.cz>2014-01-24 10:24:24 +0100
committermadmaxoft <github@xoft.cz>2014-01-24 10:24:24 +0100
commite75f979e01b34fbd1a2993be9fd4aa7211da26cf (patch)
tree970a6f325d980a24d42e7ff512b404f79dc630d8 /src/CMakeLists.txt
parentFixed a few compile-time and runtime warnings in ScoreboardSerializer. (diff)
downloadcuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.tar
cuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.tar.gz
cuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.tar.bz2
cuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.tar.lz
cuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.tar.xz
cuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.tar.zst
cuberite-e75f979e01b34fbd1a2993be9fd4aa7211da26cf.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 51182d3bc..a8cc0530d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -134,6 +134,13 @@ else ()
"StackWalker.cpp LeakFinder.h" PROPERTIES COMPILE_FLAGS "/Yc\"Globals.h\""
)
list(APPEND SOURCE "Resources/MCServer.rc")
+
+ # Make MSVC generate the PDB files even for the release build:
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /Zi")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} /Zi")
+ set(CMAKE_EXE_LINKER_FLAGS_RELEASE "${CMAKE_EXE_LINKER_FLAGS_RELEASE} /DEBUG")
+ set(CMAKE_SHARED_LINKER_FLAGS_RELEASE "${CMAKE_SHARED_LINKER_FLAGS_RELEASE} /DEBUG")
+ set(CMAKE_MODULE_LINKER_FLAGS_RELEASE "${CMAKE_MODULE_LINKER_FLAGS_RELEASE} /DEBUG")
endif()
set(EXECUTABLE MCServer)