summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2017-05-04 15:01:15 +0200
committerLukas Pioch <lukas@zgow.de>2017-05-04 17:38:05 +0200
commit0de705eb99b295d4b36b874eb944384b74d7e64a (patch)
tree9291e1feb590d9b6e4b59d91b7da01cedb5746c9 /src/CMakeLists.txt
parentGen: Added a simple PieceGeneratorBFSTree test. (diff)
downloadcuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.tar
cuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.tar.gz
cuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.tar.bz2
cuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.tar.lz
cuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.tar.xz
cuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.tar.zst
cuberite-0de705eb99b295d4b36b874eb944384b74d7e64a.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index db0372315..93a1fa368 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -310,13 +310,10 @@ if (MSVC)
ADD_CUSTOM_COMMAND(
OUTPUT ${BINDING_OUTPUTS}
- # Copy the Lua DLL into the Bindings folder, so that tolua can run from there:
- COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_SOURCE_DIR}/Server/lua51.dll ./lua51.dll
-
# Regenerate bindings:
- COMMAND tolua -L BindingsProcessor.lua -o Bindings.cpp -H Bindings.h AllToLua.pkg
+ COMMAND luaexe BindingsProcessor.lua
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/Bindings/
- DEPENDS ${BINDINGS_DEPENDENCIES} tolua
+ DEPENDS ${BINDINGS_DEPENDENCIES} luaexe
)
endif()
endif()