summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorpeterbell10 <peterbell10@live.co.uk>2020-05-10 18:16:49 +0200
committerGitHub <noreply@github.com>2020-05-10 18:16:49 +0200
commit84289a2ba996b41815f148f27aecc52a7864066d (patch)
tree7434a6b14dde1597bd687e0a71a28135a1d31adc /src/CMakeLists.txt
parentCleanup unneeded globals (#4736) (diff)
downloadcuberite-84289a2ba996b41815f148f27aecc52a7864066d.tar
cuberite-84289a2ba996b41815f148f27aecc52a7864066d.tar.gz
cuberite-84289a2ba996b41815f148f27aecc52a7864066d.tar.bz2
cuberite-84289a2ba996b41815f148f27aecc52a7864066d.tar.lz
cuberite-84289a2ba996b41815f148f27aecc52a7864066d.tar.xz
cuberite-84289a2ba996b41815f148f27aecc52a7864066d.tar.zst
cuberite-84289a2ba996b41815f148f27aecc52a7864066d.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2ee723227..e10e8e8ca 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -177,13 +177,6 @@ include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/TCLAP/include")
configure_file("BuildInfo.h.cmake" "${CMAKE_BINARY_DIR}/include/BuildInfo.h")
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set_source_files_properties(BlockType.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors")
- set_source_files_properties(ByteBuffer.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors")
- set_source_files_properties(ClientHandle.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors ")
- set_source_files_properties(Statistics.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors")
-endif()
-
if (NOT MSVC)
# Bindings need to reference other folders, so they are done here instead
# lib dependencies are not included