summaryrefslogtreecommitdiffstats
path: root/src/Entities/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2016-01-06 16:20:12 +0100
committerMattes D <github@xoft.cz>2016-01-06 16:20:12 +0100
commit491dbda7d33a154e71c68f2fd79e55436cc24eae (patch)
tree58db7ffefac6b6878f9ebc37ff7d754f56cceabd /src/Entities/CMakeLists.txt
parentMerge pull request #2844 from mathias-github/silktouch (diff)
downloadcuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.tar
cuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.tar.gz
cuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.tar.bz2
cuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.tar.lz
cuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.tar.xz
cuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.tar.zst
cuberite-491dbda7d33a154e71c68f2fd79e55436cc24eae.zip
Diffstat (limited to 'src/Entities/CMakeLists.txt')
-rw-r--r--src/Entities/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/Entities/CMakeLists.txt b/src/Entities/CMakeLists.txt
index 71964e90d..0416d5338 100644
--- a/src/Entities/CMakeLists.txt
+++ b/src/Entities/CMakeLists.txt
@@ -61,10 +61,7 @@ SET (HDRS
WitherSkullEntity.h)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set_source_files_properties(Entity.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=sign-conversion -Wno-error=global-constructors -Wno-error=switch-enum ")
- set_source_files_properties(EntityEffect.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum ")
- set_source_files_properties(Floater.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=sign-conversion ")
- set_source_files_properties(Player.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=sign-conversion -Wno-error=switch-enum -Wno-error=conversion ")
+ set_source_files_properties(Entity.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors")
endif()
if(NOT MSVC)