summaryrefslogtreecommitdiffstats
path: root/src/HTTPServer/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2015-12-25 18:50:25 +0100
committerMattes D <github@xoft.cz>2015-12-25 18:50:25 +0100
commit958df6ad9192285e0a19caa362f9f0c9e63422d4 (patch)
treeb34c37370e088e18f576357a9645fdf5c02bb0d3 /src/HTTPServer/CMakeLists.txt
parentMerge pull request #2795 from SafwatHalaby/doors (diff)
downloadcuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.tar
cuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.tar.gz
cuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.tar.bz2
cuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.tar.lz
cuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.tar.xz
cuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.tar.zst
cuberite-958df6ad9192285e0a19caa362f9f0c9e63422d4.zip
Diffstat (limited to 'src/HTTPServer/CMakeLists.txt')
-rw-r--r--src/HTTPServer/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/HTTPServer/CMakeLists.txt b/src/HTTPServer/CMakeLists.txt
index 6788d50bf..b875b9145 100644
--- a/src/HTTPServer/CMakeLists.txt
+++ b/src/HTTPServer/CMakeLists.txt
@@ -12,7 +12,9 @@ SET (SRCS
HTTPServer.cpp
MultipartParser.cpp
NameValueParser.cpp
- SslHTTPConnection.cpp)
+ SslHTTPConnection.cpp
+ UrlParser.cpp
+)
SET (HDRS
EnvelopeParser.h
@@ -22,7 +24,9 @@ SET (HDRS
HTTPServer.h
MultipartParser.h
NameValueParser.h
- SslHTTPConnection.h)
+ SslHTTPConnection.h
+ UrlParser.h
+)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set_source_files_properties(HTTPServer.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors ")