summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2014-10-24 10:13:54 +0200
committerMattes D <github@xoft.cz>2014-10-24 10:13:54 +0200
commit2940ced832e506fb1bb2b5292d49b2c7c31afb5b (patch)
tree9b5c06b80b752eda2cb5dd25d271d50d9eb1dc1f /src/OSSupport/CMakeLists.txt
parentReimplemented cEvent using C++11 primitives. (diff)
parentMerge pull request #1565 from mc-server/MergedIniFile (diff)
downloadcuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.tar
cuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.tar.gz
cuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.tar.bz2
cuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.tar.lz
cuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.tar.xz
cuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.tar.zst
cuberite-2940ced832e506fb1bb2b5292d49b2c7c31afb5b.zip
Diffstat (limited to 'src/OSSupport/CMakeLists.txt')
-rw-r--r--src/OSSupport/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index 429949c59..c3eabeef6 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -39,6 +39,10 @@ if(NOT MSVC)
add_library(OSSupport ${SRCS} ${HDRS})
if(UNIX)
- target_link_libraries(OSSupport pthread rt)
+ if(NOT APPLE)
+ target_link_libraries(OSSupport rt)
+ endif()
+
+ target_link_libraries(OSSupport pthread)
endif()
endif()