summaryrefslogtreecommitdiffstats
path: root/tests/BlockTypeRegistry/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2019-01-23 20:54:29 +0100
committerMattes D <github@xoft.cz>2019-08-05 21:42:54 +0200
commit3722a239bf1502606a3ef4f025021f23ac3fcb88 (patch)
tree037aaa22f1f132e54387f9a1c48d5c4333eb79e2 /tests/BlockTypeRegistry/CMakeLists.txt
parentCheck for nil in cWorld:SpawnSplitExperienceOrbs binding (#4354) (diff)
downloadcuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.tar
cuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.tar.gz
cuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.tar.bz2
cuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.tar.lz
cuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.tar.xz
cuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.tar.zst
cuberite-3722a239bf1502606a3ef4f025021f23ac3fcb88.zip
Diffstat (limited to 'tests/BlockTypeRegistry/CMakeLists.txt')
-rw-r--r--tests/BlockTypeRegistry/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/BlockTypeRegistry/CMakeLists.txt b/tests/BlockTypeRegistry/CMakeLists.txt
new file mode 100644
index 000000000..25b18c373
--- /dev/null
+++ b/tests/BlockTypeRegistry/CMakeLists.txt
@@ -0,0 +1,40 @@
+cmake_minimum_required(VERSION 3.0.2)
+enable_testing()
+
+include_directories(${CMAKE_SOURCE_DIR}/src/)
+
+add_definitions(-DTEST_GLOBALS=1)
+
+
+
+
+
+# Define individual test executables:
+
+# BlockTypeRegistryTest: Verify that the BlockTypeRegistry class works as intended:
+add_executable(BlockTypeRegistryTest
+ BlockTypeRegistryTest.cpp
+ ../TestHelpers.h
+ ${CMAKE_SOURCE_DIR}/src/BlockTypeRegistry.cpp
+ ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
+ ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
+)
+target_link_libraries(BlockTypeRegistryTest fmt::fmt)
+
+
+
+
+
+# Define individual tests:
+
+add_test(NAME BlockTypeRegistryTest COMMAND BlockTypeRegistryTest)
+
+
+
+
+
+# Put all the tests into a solution folder (MSVC):
+set_target_properties(
+ BlockTypeRegistryTest
+ PROPERTIES FOLDER Tests/BlockTypeRegistry
+)