summaryrefslogtreecommitdiffstats
path: root/Tools/ProtoProxy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/ProtoProxy/CMakeLists.txt')
-rw-r--r--Tools/ProtoProxy/CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/Tools/ProtoProxy/CMakeLists.txt b/Tools/ProtoProxy/CMakeLists.txt
index ea9799780..5c83123c3 100644
--- a/Tools/ProtoProxy/CMakeLists.txt
+++ b/Tools/ProtoProxy/CMakeLists.txt
@@ -7,18 +7,10 @@ set_lib_flags()
# Set include paths to the used libraries:
-include_directories("../../lib")
-include_directories("../../lib/polarssl/include")
+include_directories(SYSTEM "../../lib")
+include_directories(SYSTEM "../../lib/polarssl/include")
include_directories("../../src")
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_flags_cxx("-Wno-error=sign-conversion -Wno-error=conversion -Wno-error=shorten-64-to-32")
- add_flags_cxx("-Wno-error=old-style-cast")
- if ("${CLANG_VERSION}" VERSION_GREATER 3.5)
- add_flags_cxx("-Wno-error=keyword-macro")
- endif()
-endif()
-
function(flatten_files arg1)
set(res "")
foreach(f ${${arg1}})