summaryrefslogtreecommitdiffstats
path: root/lib/cryptopp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/cryptopp/CMakeLists.txt')
-rw-r--r--lib/cryptopp/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/cryptopp/CMakeLists.txt b/lib/cryptopp/CMakeLists.txt
new file mode 100644
index 000000000..daa16ca53
--- /dev/null
+++ b/lib/cryptopp/CMakeLists.txt
@@ -0,0 +1,10 @@
+
+cmake_minimum_required (VERSION 2.6)
+project (cryptopp)
+
+if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DCRYPTOPP_DISABLE_ASM")
+endif()
+include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
+
+add_library(cryptopp rsa integer queue secblock misc randpool pch asn oids modarith nbtheory sha algparam fips140 pssr aes hrtimer cryptlib filters pubkey algebra simple pkcspad iterhash emsa2 eprecomp cpu rijndael)