summaryrefslogtreecommitdiffstats
path: root/lib/cryptopp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/cryptopp/CMakeLists.txt')
-rw-r--r--lib/cryptopp/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/cryptopp/CMakeLists.txt b/lib/cryptopp/CMakeLists.txt
new file mode 100644
index 000000000..3497b3346
--- /dev/null
+++ b/lib/cryptopp/CMakeLists.txt
@@ -0,0 +1,14 @@
+
+cmake_minimum_required (VERSION 2.6)
+project (cryptopp)
+
+if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DCRYPTOPP_DISABLE_ASM")
+endif()
+include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
+
+file(GLOB cryptopp_SRC
+ "*.cpp"
+)
+
+add_library(cryptopp ${cryptopp_SRC})