summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fcafdbe87..d8a72a360 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -376,4 +376,5 @@ if (${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
add_flags_lnk(-L/usr/local/lib)
endif()
-target_link_libraries(${EXECUTABLE} luaexpat jsoncpp mbedtls zlib sqlite lua SQLiteCpp event_core event_extra)
+find_library(JSONCPP_LIBRARY jsoncpp ../lib/jsoncpp/src/lib_json)
+target_link_libraries(${EXECUTABLE} luaexpat ${JSONCPP_LIBRARY} mbedtls zlib sqlite lua SQLiteCpp event_core event_extra)