summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7ba7e9469..997326cc7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -104,7 +104,6 @@ SET (HDRS
Inventory.h
Item.h
ItemGrid.h
- LeakFinder.h
LightingThread.h
LineBlockTracer.h
LinearInterpolation.h
@@ -114,7 +113,6 @@ SET (HDRS
Map.h
MapManager.h
Matrix4.h
- MemoryLeak.h
MobCensus.h
MobFamilyCollecter.h
MobProximityCounter.h
@@ -127,7 +125,6 @@ SET (HDRS
Scoreboard.h
Server.h
SetChunkData.h
- StackWalker.h
Statistics.h
StringCompression.h
StringUtils.h
@@ -175,6 +172,10 @@ if (NOT MSVC)
else ()
# MSVC-specific handling: Put all files into one project, separate by the folders:
+ # Add the MSVC-specific LeakFinder sources:
+ list (APPEND SRCS LeakFinder.cpp StackWalker.cpp)
+ list (APPEND HDRS LeakFinder.h StackWalker.h MemoryLeak.h)
+
source_group(Bindings FILES "Bindings/Bindings.cpp" "Bindings/Bindings.h")
# Add all subfolders as solution-folders:
@@ -224,7 +225,7 @@ else ()
Bindings/Bindings.cpp PROPERTIES COMPILE_FLAGS "/Yc\"string.h\" /Fp\"$(IntDir)/Bindings.pch\""
)
SET_SOURCE_FILES_PROPERTIES(
- "StackWalker.cpp LeakFinder.h" PROPERTIES COMPILE_FLAGS "/Yc\"Globals.h\""
+ "StackWalker.cpp LeakFinder.cpp" PROPERTIES COMPILE_FLAGS "/Yc\"Globals.h\""
)
list(APPEND SOURCE "Resources/MCServer.rc")