summaryrefslogtreecommitdiffstats
path: root/src/Generating/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Generating/CMakeLists.txt')
-rw-r--r--src/Generating/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/Generating/CMakeLists.txt b/src/Generating/CMakeLists.txt
index 713e5b8c9..d6f0ce2fb 100644
--- a/src/Generating/CMakeLists.txt
+++ b/src/Generating/CMakeLists.txt
@@ -1,5 +1,6 @@
+target_sources(
+ ${CMAKE_PROJECT_NAME} PRIVATE
-SET (SRCS
BioGen.cpp
Caves.cpp
ChunkDesc.cpp
@@ -29,9 +30,7 @@ SET (SRCS
VerticalLimit.cpp
VerticalStrategy.cpp
VillageGen.cpp
-)
-SET (HDRS
BioGen.h
Caves.h
ChunkDesc.h
@@ -66,8 +65,3 @@ SET (HDRS
VerticalStrategy.h
VillageGen.h
)
-
-if(NOT MSVC)
- add_library(Generating ${SRCS} ${HDRS})
- target_link_libraries(Generating fmt::fmt OSSupport Blocks Bindings)
-endif()