summaryrefslogtreecommitdiffstats
path: root/src/Mobs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Mobs/CMakeLists.txt')
-rw-r--r--src/Mobs/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/src/Mobs/CMakeLists.txt b/src/Mobs/CMakeLists.txt
index aada8f3a8..6508e1814 100644
--- a/src/Mobs/CMakeLists.txt
+++ b/src/Mobs/CMakeLists.txt
@@ -1,5 +1,6 @@
+target_sources(
+ ${CMAKE_PROJECT_NAME} PRIVATE
-SET (SRCS
AggressiveMonster.cpp
Bat.cpp
Blaze.cpp
@@ -37,9 +38,8 @@ SET (SRCS
Wolf.cpp
Zombie.cpp
ZombiePigman.cpp
- ZombieVillager.cpp)
+ ZombieVillager.cpp
-SET (HDRS
AggressiveMonster.h
Bat.h
Blaze.h
@@ -80,9 +80,5 @@ SET (HDRS
Wolf.h
Zombie.h
ZombiePigman.h
- ZombieVillager.h)
-
-if(NOT MSVC)
- add_library(Mobs ${SRCS} ${HDRS})
- target_link_libraries(Mobs fmt::fmt SQLiteCpp)
-endif()
+ ZombieVillager.h
+)