summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/OSSupport/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index 8004d4094..a42fcbed4 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -35,8 +35,10 @@ SET (HDRS
Thread.h
Timer.h)
-add_library(OSSupport ${SRCS} ${HDRS})
+if(NOT MSVC)
+ add_library(OSSupport ${SRCS} ${HDRS})
-if(UNIX)
- target_link_libraries(OSSupport pthread)
+ if(UNIX)
+ target_link_libraries(OSSupport pthread)
+ endif()
endif()