summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/OSSupport/CMakeLists.txt')
-rw-r--r--src/OSSupport/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index dbf5dcc7a..e559ca681 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -3,7 +3,9 @@ cmake_minimum_required (VERSION 2.6)
project (MCServer)
include_directories ("${PROJECT_SOURCE_DIR}/../")
-set(SOURCE CriticalSection Timer Thread Sleep IsThread Event SocketThreads ListenThread)
-set(SOURCE ${SOURCE} BlockingTCPLink Socket File)
+file(GLOB SOURCE
+ "*.h"
+ "*.cpp"
+)
add_library(OSSupport ${SOURCE})