summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/OSSupport/CMakeLists.txt')
-rw-r--r--src/OSSupport/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index 429949c59..c3eabeef6 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -39,6 +39,10 @@ if(NOT MSVC)
add_library(OSSupport ${SRCS} ${HDRS})
if(UNIX)
- target_link_libraries(OSSupport pthread rt)
+ if(NOT APPLE)
+ target_link_libraries(OSSupport rt)
+ endif()
+
+ target_link_libraries(OSSupport pthread)
endif()
endif()