summaryrefslogtreecommitdiffstats
path: root/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt')
-rw-r--r--src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt b/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
new file mode 100644
index 000000000..e37f3595c
--- /dev/null
+++ b/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
@@ -0,0 +1,38 @@
+cmake_minimum_required (VERSION 2.6)
+project (MCServer)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../")
+
+set (SRCS
+ IncrementalRedstoneSimulator.cpp
+)
+
+set (HDRS
+ CommandBlockHandler.h
+ DoorHandler.h
+ DropSpenserHandler.h
+ IncrementalRedstoneSimulator.h
+ RedstoneHandler.h
+ RedstoneSimulatorChunkData.h
+ SolidBlockHandler.h
+ RedstoneComparatorHandler.h
+ RedstoneRepeaterHandler.h
+ RedstoneBlockHandler.h
+ RedstoneTorchHandler.h
+ RedstoneWireHandler.h
+ RedstoneLampHandler.h
+ RedstoneToggleHandler.h
+ PistonHandler.h
+ SmallGateHandler.h
+ NoteBlockHandler.h
+ TNTHandler.h
+ TrappedChestHandler.h
+ TripwireHookHandler.h
+ PoweredRailHandler.h
+ PressurePlateHandler.h
+)
+
+if(NOT MSVC)
+ add_library(IncrementalRedstoneSimulator ${SRCS} ${HDRS})
+endif()
+