summaryrefslogtreecommitdiffstats
path: root/src/UI/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/UI/CMakeLists.txt')
-rw-r--r--src/UI/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/src/UI/CMakeLists.txt b/src/UI/CMakeLists.txt
index 16c70f6fe..b87a7fe47 100644
--- a/src/UI/CMakeLists.txt
+++ b/src/UI/CMakeLists.txt
@@ -1,5 +1,6 @@
+target_sources(
+ ${CMAKE_PROJECT_NAME} PRIVATE
-SET (SRCS
SlotArea.cpp
Window.cpp
AnvilWindow.cpp
@@ -13,9 +14,8 @@ SET (SRCS
FurnaceWindow.cpp
HopperWindow.cpp
HorseWindow.cpp
- InventoryWindow.cpp)
+ InventoryWindow.cpp
-SET (HDRS
SlotArea.h
Window.h
AnvilWindow.h
@@ -31,9 +31,5 @@ SET (HDRS
HorseWindow.h
InventoryWindow.h
MinecartWithChestWindow.h
- WindowOwner.h)
-
-if(NOT MSVC)
- add_library(UI ${SRCS} ${HDRS})
- target_link_libraries(UI fmt::fmt SQLiteCpp)
-endif()
+ WindowOwner.h
+)