summaryrefslogtreecommitdiffstats
path: root/tests/BlockTypeRegistry/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/BlockTypeRegistry/CMakeLists.txt')
-rw-r--r--tests/BlockTypeRegistry/CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/tests/BlockTypeRegistry/CMakeLists.txt b/tests/BlockTypeRegistry/CMakeLists.txt
index 1b2749722..ef4803747 100644
--- a/tests/BlockTypeRegistry/CMakeLists.txt
+++ b/tests/BlockTypeRegistry/CMakeLists.txt
@@ -1,14 +1,6 @@
-cmake_minimum_required(VERSION 3.0.2)
-enable_testing()
-
+find_package(Threads REQUIRED)
include_directories(${CMAKE_SOURCE_DIR}/src/)
-add_definitions(-DTEST_GLOBALS=1)
-
-
-
-
-
# Define individual test executables:
# BlockStateTest: Verify that the BlockState class works as intended:
@@ -41,7 +33,7 @@ add_executable(BlockTypeRegistryTest
${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
)
-target_link_libraries(BlockTypeRegistryTest fmt::fmt)
+target_link_libraries(BlockTypeRegistryTest fmt::fmt Threads::Threads)
# PalettedBlockAreaTest: Verify that the PalettedBlockArea class works as intended:
add_executable(PalettedBlockAreaTest