summaryrefslogtreecommitdiffstats
path: root/tests/Generating/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Generating/CMakeLists.txt')
-rw-r--r--tests/Generating/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Generating/CMakeLists.txt b/tests/Generating/CMakeLists.txt
index 0232b7a8a..cfdae6c68 100644
--- a/tests/Generating/CMakeLists.txt
+++ b/tests/Generating/CMakeLists.txt
@@ -3,6 +3,7 @@ enable_testing()
include_directories(${CMAKE_SOURCE_DIR}/src/)
include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/)
+include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/mbedtls/include)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
add_definitions(-DTEST_GLOBALS=1)
@@ -168,8 +169,9 @@ source_group("Generating" FILES ${GENERATING_HDRS} ${GENERATING_SRCS})
add_executable(BasicGeneratorTest
BasicGeneratorTest.cpp
${CMAKE_SOURCE_DIR}/src/IniFile.cpp
+ ${CMAKE_SOURCE_DIR}/src/mbedTLS++/Sha1Checksum.cpp
)
-target_link_libraries(BasicGeneratorTest GeneratorTestingSupport)
+target_link_libraries(BasicGeneratorTest GeneratorTestingSupport mbedtls)
file(COPY "${CMAKE_SOURCE_DIR}/Server/items.ini" DESTINATION "${CMAKE_CURRENT_BINARY_DIR}")
add_test(
NAME BasicGeneratorTest