summaryrefslogtreecommitdiffstats
path: root/tests/Generating/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Generating/CMakeLists.txt')
-rw-r--r--tests/Generating/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/Generating/CMakeLists.txt b/tests/Generating/CMakeLists.txt
index 4efb9dbe2..269ab50ab 100644
--- a/tests/Generating/CMakeLists.txt
+++ b/tests/Generating/CMakeLists.txt
@@ -112,10 +112,24 @@ add_test(NAME PieceRotation-test WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} C
+# PieceGeneratorBFSTree test:
+add_executable(PieceGeneratorBFSTree
+ PieceGeneratorBFSTreeTest.cpp
+ ${CMAKE_SOURCE_DIR}/src/Generating/PieceGeneratorBFSTree.cpp
+ ${CMAKE_SOURCE_DIR}/src/Generating/PieceGeneratorBFSTree.h
+)
+target_link_libraries(PieceGeneratorBFSTree GeneratorTestingSupport)
+add_test(NAME PieceGeneratorBFSTree-test WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/Server/Prefabs/PieceStructures COMMAND PieceGeneratorBFSTree)
+
+
+
+
+
# Put the projects into solution folders (MSVC):
set_target_properties(
GeneratorTestingSupport
LoadablePieces
+ PieceGeneratorBFSTree
PieceRotation
PROPERTIES FOLDER Tests/Generating
)