summaryrefslogtreecommitdiffstats
path: root/tests/HTTP/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/HTTP/CMakeLists.txt')
-rw-r--r--tests/HTTP/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/tests/HTTP/CMakeLists.txt b/tests/HTTP/CMakeLists.txt
index 04e82caf9..5529ed082 100644
--- a/tests/HTTP/CMakeLists.txt
+++ b/tests/HTTP/CMakeLists.txt
@@ -1,8 +1,8 @@
enable_testing()
include_directories(${CMAKE_SOURCE_DIR}/src/)
-include_directories(${CMAKE_SOURCE_DIR}/lib/libevent/include)
-include_directories(${CMAKE_SOURCE_DIR}/lib/polarssl/include)
+include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/libevent/include)
+include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/polarssl/include)
add_definitions(-DTEST_GLOBALS=1)
@@ -37,9 +37,6 @@ add_library(HTTP
)
target_link_libraries(HTTP Network OSSupport)
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_flags_cxx("-Wno-error=conversion -Wno-error=old-style-cast")
-endif()