summaryrefslogtreecommitdiffstats
path: root/tests/Network/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Network/CMakeLists.txt')
-rw-r--r--tests/Network/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/tests/Network/CMakeLists.txt b/tests/Network/CMakeLists.txt
index c6c76385e..f3496d276 100644
--- a/tests/Network/CMakeLists.txt
+++ b/tests/Network/CMakeLists.txt
@@ -1,8 +1,8 @@
enable_testing()
include_directories(${CMAKE_SOURCE_DIR}/src/)
-include_directories(${CMAKE_SOURCE_DIR}/lib/libevent/include)
-include_directories(${CMAKE_SOURCE_DIR}/lib/polarssl/include)
+include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/libevent/include)
+include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/polarssl/include)
add_definitions(-DTEST_GLOBALS=1)
@@ -51,12 +51,9 @@ if (MSVC)
target_link_libraries(Network ws2_32.lib)
endif()
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_flags_cxx("-Wno-error=conversion -Wno-error=old-style-cast")
- if ("${CLANG_VERSION}" VERSION_GREATER 3.5)
- add_flags_cxx("-Wno-error=inconsistent-missing-override")
- endif()
-endif()
+
+
+
# Define individual tests: