summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/tls_client-0.2.dist-info
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/tls_client-0.2.dist-info')
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/INSTALLER1
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/LICENSE21
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/METADATA277
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/RECORD32
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/REQUESTED0
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/WHEEL5
-rw-r--r--venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/top_level.txt1
7 files changed, 337 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/INSTALLER b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/INSTALLER
new file mode 100644
index 00000000..a1b589e3
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/INSTALLER
@@ -0,0 +1 @@
+pip
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/LICENSE b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/LICENSE
new file mode 100644
index 00000000..c60429dd
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2022 Florian Zager
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/METADATA b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/METADATA
new file mode 100644
index 00000000..ff576278
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/METADATA
@@ -0,0 +1,277 @@
+Metadata-Version: 2.1
+Name: tls-client
+Version: 0.2
+Summary: Advanced Python HTTP Client.
+Home-page: UNKNOWN
+Author: Florian Zager
+License: MIT
+Platform: UNKNOWN
+Classifier: Environment :: Web Environment
+Classifier: Intended Audience :: Developers
+Classifier: Natural Language :: English
+Classifier: Operating System :: Unix
+Classifier: Operating System :: MacOS :: MacOS X
+Classifier: Operating System :: Microsoft :: Windows
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 3
+Classifier: Topic :: Internet :: WWW/HTTP
+Classifier: Topic :: Software Development :: Libraries
+Description-Content-Type: text/markdown
+License-File: LICENSE
+
+# Python-TLS-Client
+
+Python-TLS-Client is an advanced HTTP library based on requests and tls-client.
+
+
+
+# Installation
+
+```
+
+pip install tls-client
+
+```
+
+
+
+# Examples
+
+The syntax is inspired by [requests](https://github.com/psf/requests), so its very similar and there are only very few things that are different.
+
+
+
+Example 1 - Preset:
+
+```python
+
+import tls_client
+
+
+
+# You can also use the following as `client_identifier`:
+
+# Chrome --> chrome_103, chrome_104, chrome_105, chrome_106, chrome_107, chrome_108, chrome109, Chrome110
+
+# Firefox --> firefox_102, firefox_104, firefox108, Firefox110
+
+# Opera --> opera_89, opera_90
+
+# Safari --> safari_15_3, safari_15_6_1, safari_16_0
+
+# iOS --> safari_ios_15_5, safari_ios_15_6, safari_ios_16_0
+
+# iPadOS --> safari_ios_15_6
+
+# Android --> okhttp4_android_7, okhttp4_android_8, okhttp4_android_9, okhttp4_android_10, okhttp4_android_11,
+
+# okhttp4_android_12, okhttp4_android_13
+
+
+
+session = tls_client.Session(
+
+ client_identifier="chrome110",
+
+ random_tls_extension_order=True
+
+)
+
+
+
+res = session.get(
+
+ "https://www.example.com/",
+
+ headers={
+
+ "key1": "value1",
+
+ },
+
+ proxy="http://user:password@host:port"
+
+)
+
+```
+
+
+
+Example 2 - Custom:
+
+```python
+
+import tls_client
+
+
+
+session = tls_client.Session(
+
+ ja3_string="771,4865-4866-4867-49195-49199-49196-49200-52393-52392-49171-49172-156-157-47-53,0-23-65281-10-11-35-16-5-13-18-51-45-43-27-17513,29-23-24,0",
+
+ h2_settings={
+
+ "HEADER_TABLE_SIZE": 65536,
+
+ "MAX_CONCURRENT_STREAMS": 1000,
+
+ "INITIAL_WINDOW_SIZE": 6291456,
+
+ "MAX_HEADER_LIST_SIZE": 262144
+
+ },
+
+ h2_settings_order=[
+
+ "HEADER_TABLE_SIZE",
+
+ "MAX_CONCURRENT_STREAMS",
+
+ "INITIAL_WINDOW_SIZE",
+
+ "MAX_HEADER_LIST_SIZE"
+
+ ],
+
+ supported_signature_algorithms=[
+
+ "ECDSAWithP256AndSHA256",
+
+ "PSSWithSHA256",
+
+ "PKCS1WithSHA256",
+
+ "ECDSAWithP384AndSHA384",
+
+ "PSSWithSHA384",
+
+ "PKCS1WithSHA384",
+
+ "PSSWithSHA512",
+
+ "PKCS1WithSHA512",
+
+ ],
+
+ supported_versions=["GREASE", "1.3", "1.2"],
+
+ key_share_curves=["GREASE", "X25519"],
+
+ cert_compression_algo="brotli",
+
+ pseudo_header_order=[
+
+ ":method",
+
+ ":authority",
+
+ ":scheme",
+
+ ":path"
+
+ ],
+
+ connection_flow=15663105,
+
+ header_order=[
+
+ "accept",
+
+ "user-agent",
+
+ "accept-encoding",
+
+ "accept-language"
+
+ ]
+
+)
+
+
+
+res = session.post(
+
+ "https://www.example.com/",
+
+ headers={
+
+ "key1": "value1",
+
+ },
+
+ json={
+
+ "key1": "key2"
+
+ }
+
+)
+
+```
+
+
+
+# Pyinstaller / Pyarmor
+
+**If you want to pack the library with Pyinstaller or Pyarmor, make sure to add this to your command:**
+
+
+
+Linux - Ubuntu / x86:
+
+```
+
+--add-binary '{path_to_library}/tls_client/dependencies/tls-client-x86.so:tls_client/dependencies'
+
+```
+
+
+
+Linux Alpine / AMD64:
+
+```
+
+--add-binary '{path_to_library}/tls_client/dependencies/tls-client-amd64.so:tls_client/dependencies'
+
+```
+
+
+
+MacOS M1 and older:
+
+```
+
+--add-binary '{path_to_library}/tls_client/dependencies/tls-client-x86.dylib:tls_client/dependencies'
+
+```
+
+
+
+MacOS M2:
+
+```
+
+--add-binary '{path_to_library}/tls_client/dependencies/tls-client-arm64.dylib:tls_client/dependencies'
+
+```
+
+
+
+Windows:
+
+```
+
+--add-binary '{path_to_library}/tls_client/dependencies/tls-client-64.dll;tls_client/dependencies'
+
+```
+
+
+
+# Acknowledgements
+
+Big shout out to [Bogdanfinn](https://github.com/bogdanfinn) for open sourcing his [tls-client](https://github.com/bogdanfinn/tls-client) in Golang.
+
+Also I wanted to keep the syntax as similar as possible to [requests](https://github.com/psf/requests), as most people use it and are familiar with it!
+
+
+
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/RECORD b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/RECORD
new file mode 100644
index 00000000..043fbb0b
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/RECORD
@@ -0,0 +1,32 @@
+tls_client-0.2.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
+tls_client-0.2.dist-info/LICENSE,sha256=scQlqmvsx5lEhptXddCTxlJUmA3gMUEESzBsZoqq7TQ,1091
+tls_client-0.2.dist-info/METADATA,sha256=3xcpfDmqCom1gKd6vLtGIr9lSoeBd5deP_wRfjMeXug,4437
+tls_client-0.2.dist-info/RECORD,,
+tls_client-0.2.dist-info/REQUESTED,sha256=47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU,0
+tls_client-0.2.dist-info/WHEEL,sha256=OqRkF0eY5GHssMorFjlbTIq072vpHpF60fIQA6lS9xA,92
+tls_client-0.2.dist-info/top_level.txt,sha256=yLrfQtbTRfECzPN62knWdGNmbhcPRev1grCAMuEsEz0,11
+tls_client/__init__.py,sha256=sThiIAzA650rfBlqZ_xalTjgTysUsjKua5ODnqyvhUE,669
+tls_client/__pycache__/__init__.cpython-39.pyc,,
+tls_client/__pycache__/__version__.cpython-39.pyc,,
+tls_client/__pycache__/cffi.cpython-39.pyc,,
+tls_client/__pycache__/cookies.cpython-39.pyc,,
+tls_client/__pycache__/exceptions.cpython-39.pyc,,
+tls_client/__pycache__/response.cpython-39.pyc,,
+tls_client/__pycache__/sessions.cpython-39.pyc,,
+tls_client/__pycache__/structures.cpython-39.pyc,,
+tls_client/__version__.py,sha256=MnZKRg-qPYJrFCLO-RetEltQ5SlEL51qhPouPhOqvgM,393
+tls_client/cffi.py,sha256=_qGkZq-XnoBtc_MlvcTSMa5lLchyBV3fjIGyoeAzUHs,896
+tls_client/cookies.py,sha256=z9Lj0bsH6pY1fnlNFd7m7MRa2-omNMSosowhBVc9vhU,15867
+tls_client/dependencies/__init__.py,sha256=47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU,0
+tls_client/dependencies/__pycache__/__init__.cpython-39.pyc,,
+tls_client/dependencies/tls-client-32.dll,sha256=RRUx11RhPlMZC4dcXTbxuiVk0YNdbARIvLl-Mxnwsvg,13783646
+tls_client/dependencies/tls-client-64.dll,sha256=5j2b6dvXyPsqUmnR7beGSXPh3P8ekX-c8MJrSekqrjM,15477617
+tls_client/dependencies/tls-client-amd64.so,sha256=wicII_I_ZkG2RvFc4AkWilfIcOlYdzSDAD9DNCpCD-I,10091584
+tls_client/dependencies/tls-client-arm64.dylib,sha256=laZgjQui6nHVLdXGpfnBd0QXOAQQQ0NMKojUjwZr_c4,9358546
+tls_client/dependencies/tls-client-arm64.so,sha256=g-CzdWh6kgF4sXlTpEx1HeJsCRqSSZIeOBQsVH8MvfI,9628680
+tls_client/dependencies/tls-client-x86.dylib,sha256=YuuwxvDVCwvwYOD9aAqj1eUXjK2rRkmLooRFyCIL0PE,9824464
+tls_client/dependencies/tls-client-x86.so,sha256=mNDzpzRo60P1AxxhgMIPLYEyn6M2TCg3eH6b6ksm8qk,10096784
+tls_client/exceptions.py,sha256=xIoFb5H3Suk7XssQ-yw3I1DBkPLqnDXsiAe2MMp1qNQ,80
+tls_client/response.py,sha256=bstvJzernK9lDNZ7bx-WqKnwi3ztEmXRf3Uj8Xrkm04,2493
+tls_client/sessions.py,sha256=5f3wjy0OZFyIhYUcvPuhVeG_cKa6hOrPwswhw--nFeg,16640
+tls_client/structures.py,sha256=md-tJmo8X5bad0KrMUTVN8jxUIvui7NiBxaf10bLULU,2517
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/REQUESTED b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/REQUESTED
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/REQUESTED
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/WHEEL b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/WHEEL
new file mode 100644
index 00000000..385faab0
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/WHEEL
@@ -0,0 +1,5 @@
+Wheel-Version: 1.0
+Generator: bdist_wheel (0.36.2)
+Root-Is-Purelib: true
+Tag: py3-none-any
+
diff --git a/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/top_level.txt b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/top_level.txt
new file mode 100644
index 00000000..7a41aa26
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/tls_client-0.2.dist-info/top_level.txt
@@ -0,0 +1 @@
+tls_client