From f3c40f4a208117ceb49396a381702b01c40efdb0 Mon Sep 17 00:00:00 2001
From: Morph <39850852+Morph1984@users.noreply.github.com>
Date: Fri, 21 Oct 2022 02:34:06 -0400
Subject: CMakeLists: Treat MSVC warnings as errors

---
 src/CMakeLists.txt | 2 ++
 1 file changed, 2 insertions(+)

(limited to 'src/CMakeLists.txt')

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cfd80886c..397c1fa23 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -58,6 +58,8 @@ if (MSVC)
 
         # Warnings
         /W3
+        /WX
+
         /we4018 # 'expression': signed/unsigned mismatch
         /we4062 # Enumerator 'identifier' in a switch of enum 'enumeration' is not handled
         /we4101 # 'identifier': unreferenced local variable
-- 
cgit v1.2.3