summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 12ae824..7d703cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,8 +48,8 @@ CPMAddPackage(
VERSION 2.0.14
GIT_TAG release-2.0.14
OPTIONS
- "SDL_SHARED ON"
- "SDL_STATIC OFF"
+ "SDL_SHARED OFF"
+ "SDL_STATIC ON"
)
@@ -89,7 +89,7 @@ if(SDL2_net_ADDED)
file(GLOB SDL2_net_sources ${SDL2_net_SOURCE_DIR}/*.c)
list(REMOVE_ITEM SDL2_net_sources "${SDL2_net_SOURCE_DIR}/chatd.c")
add_library(SDL2_net STATIC ${SDL2_net_sources})
- target_link_libraries(SDL2_net SDL2)
+ target_link_libraries(SDL2_net SDL2-static)
IF (WIN32)
target_link_libraries(SDL2_net ws2_32 iphlpapi)
ENDIF()
@@ -102,8 +102,8 @@ CPMAddPackage(
GITHUB_REPOSITORY madler/zlib
VERSION 1.2.11
)
-target_include_directories(zlib PUBLIC ${zlib_SOURCE_DIR})
-target_include_directories(zlib PUBLIC ${zlib_BINARY_DIR})
+target_include_directories(zlibstatic PUBLIC ${zlib_SOURCE_DIR})
+target_include_directories(zlibstatic PUBLIC ${zlib_BINARY_DIR})
CPMAddPackage(
@@ -181,17 +181,17 @@ target_link_libraries(AltCraft
easyloggingpp
libglew_static
nlohmann_json::nlohmann_json
- SDL2
+ SDL2-static
SDL2main
SDL2_net
OptickCore
- zlib
+ zlibstatic
sol2
RmlLua
RmlDebugger
)
-set_target_properties(AltCraft SDL2 OptickCore zlib PROPERTIES
+set_target_properties(AltCraft OptickCore PROPERTIES
RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}
)