summaryrefslogtreecommitdiffstats
path: root/libpit/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Dobell <benjamin.dobell+git@glassechidna.com.au>2014-11-16 21:02:07 +0100
committerBenjamin Dobell <benjamin.dobell+git@glassechidna.com.au>2014-11-16 21:02:39 +0100
commit1ddfdc1a880279ce07b2c43f60b7aa138d4ad315 (patch)
tree4ea142d9013a6dfdf84cab401f561d45ff8ccad4 /libpit/CMakeLists.txt
parentMore empty transfer craziness, this time when receving packets (diff)
downloadHeimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.tar
Heimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.tar.gz
Heimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.tar.bz2
Heimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.tar.lz
Heimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.tar.xz
Heimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.tar.zst
Heimdall-1ddfdc1a880279ce07b2c43f60b7aa138d4ad315.zip
Diffstat (limited to 'libpit/CMakeLists.txt')
-rw-r--r--libpit/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/libpit/CMakeLists.txt b/libpit/CMakeLists.txt
new file mode 100644
index 0000000..8d12868
--- /dev/null
+++ b/libpit/CMakeLists.txt
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 2.8.4)
+project(libpit)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
+
+set(LIBPIT_SOURCE_FILES
+ Source/libpit.cpp
+ Source/libpit.h)
+
+add_library(pit STATIC ${LIBPIT_SOURCE_FILES})