summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHowaner <franzi.moos@googlemail.com>2014-11-14 22:33:54 +0100
committerHowaner <franzi.moos@googlemail.com>2014-11-14 22:33:54 +0100
commita0e1e43fc187d79021b4e84e70729255f7f690e2 (patch)
tree933304dcec7bc698bf7c0f70fe8938d46c642113 /CMakeLists.txt
parent... in this world (diff)
parentNoise3D: Added jungles. (diff)
downloadcuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.tar
cuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.tar.gz
cuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.tar.bz2
cuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.tar.lz
cuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.tar.xz
cuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.tar.zst
cuberite-a0e1e43fc187d79021b4e84e70729255f7f690e2.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66281fe0c..d4e9d41e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,21 @@ if(DEFINED ENV{MCSERVER_BUILD_ID})
endif()
endif()
+# We need C++11 features, Visual Studio has those from VS2012, but it needs a new platform toolset for those; VS2013 supports them natively:
+# Adapted from http://binglongx.wordpress.com/2013/06/28/set-non-default-platform-toolset-in-cmake/
+if(MSVC OR MSVC_IDE)
+ if( MSVC_VERSION LESS 1700 ) # VC10- / VS2010-
+ message(FATAL_ERROR "The project requires C++11 features. "
+ "You need at least Visual Studio 11 (Microsoft Visual Studio 2012), "
+ "with Microsoft Visual C++ Compiler Nov 2012 CTP (v120_CTP_Nov2012).")
+ elseif( MSVC_VERSION EQUAL 1700 ) # VC11 / VS2012
+ message( "VC11: using Microsoft Visual Studio 2012 "
+ "with Microsoft Visual C++ Compiler Nov 2012 CTP (v120_CTP_Nov2012)" )
+ set(CMAKE_GENERATOR_TOOLSET "v120_CTP_Nov2012" CACHE STRING "Platform Toolset" FORCE)
+ else() # VC12+, assuming C++11 supported.
+ endif()
+endif()
+
# This has to be done before any flags have been set up.
if(${BUILD_TOOLS})
add_subdirectory(Tools/MCADefrag/)