summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authormadmaxoft <github@xoft.cz>2014-02-10 23:23:04 +0100
committermadmaxoft <github@xoft.cz>2014-02-10 23:23:04 +0100
commitde7bf126dbd6601272eac725955394691631a527 (patch)
tree01b8d50e8776925b18c4c45046177006c2f2d4bc /src/CMakeLists.txt
parentDebuggers: Updated to reflect the new API. (diff)
downloadcuberite-de7bf126dbd6601272eac725955394691631a527.tar
cuberite-de7bf126dbd6601272eac725955394691631a527.tar.gz
cuberite-de7bf126dbd6601272eac725955394691631a527.tar.bz2
cuberite-de7bf126dbd6601272eac725955394691631a527.tar.lz
cuberite-de7bf126dbd6601272eac725955394691631a527.tar.xz
cuberite-de7bf126dbd6601272eac725955394691631a527.tar.zst
cuberite-de7bf126dbd6601272eac725955394691631a527.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt83
1 files changed, 47 insertions, 36 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 50caf5f4f..6ba952f92 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -20,60 +20,60 @@ if (NOT MSVC)
set(BINDING_DEPENDECIES
${CMAKE_CURRENT_SOURCE_DIR}/Bindings/virtual_method_hooks.lua
${CMAKE_CURRENT_SOURCE_DIR}/Bindings/AllToLua.pkg
- ChunkDef.h
- BiomeDef.h
- OSSupport/File.h
Bindings/LuaFunctions.h
- Bindings/PluginManager.h
+ Bindings/LuaWindow.h
Bindings/Plugin.h
Bindings/PluginLua.h
+ Bindings/PluginManager.h
Bindings/WebPlugin.h
- Bindings/LuaWindow.h
+ BiomeDef.h
+ BlockArea.h
+ BlockEntities/BlockEntity.h
+ BlockEntities/BlockEntityWithItems.h
+ BlockEntities/ChestEntity.h
+ BlockEntities/DispenserEntity.h
+ BlockEntities/DropSpenserEntity.h
+ BlockEntities/DropperEntity.h
+ BlockEntities/FurnaceEntity.h
+ BlockEntities/HopperEntity.h
+ BlockEntities/JukeboxEntity.h
+ BlockEntities/NoteEntity.h
+ BlockEntities/SignEntity.h
BlockID.h
- StringUtils.h
- Defines.h
+ BoundingBox.h
ChatColor.h
+ ChunkDef.h
ClientHandle.h
+ CraftingRecipes.h
+ Cuboid.h
+ Defines.h
+ Enchantments.h
+ Entities/Effects.h
Entities/Entity.h
Entities/Floater.h
Entities/Pawn.h
- Entities/Player.h
Entities/Pickup.h
+ Entities/Player.h
Entities/ProjectileEntity.h
Entities/TNTEntity.h
- Entities/Effects.h
- Server.h
- World.h
+ Generating/ChunkDesc.h
+ Group.h
Inventory.h
- Enchantments.h
Item.h
ItemGrid.h
- BlockEntities/BlockEntity.h
- BlockEntities/BlockEntityWithItems.h
- BlockEntities/ChestEntity.h
- BlockEntities/DropSpenserEntity.h
- BlockEntities/DispenserEntity.h
- BlockEntities/DropperEntity.h
- BlockEntities/FurnaceEntity.h
- BlockEntities/HopperEntity.h
- BlockEntities/JukeboxEntity.h
- BlockEntities/NoteEntity.h
- BlockEntities/SignEntity.h
- WebAdmin.h
- Root.h
- Vector3f.h
- Vector3d.h
- Vector3i.h
Matrix4f.h
- Cuboid.h
- BoundingBox.h
+ Mobs/Monster.h
+ OSSupport/File.h
+ Root.h
+ Server.h
+ StringUtils.h
Tracer.h
- Group.h
- BlockArea.h
- Generating/ChunkDesc.h
- CraftingRecipes.h
UI/Window.h
- Mobs/Monster.h
+ Vector3d.h
+ Vector3f.h
+ Vector3i.h
+ WebAdmin.h
+ World.h
)
include_directories(Bindings)
@@ -91,7 +91,18 @@ if (NOT MSVC)
DEPENDS ${BINDING_DEPENDECIES}
)
#add cpp files here
- add_library(Bindings Bindings/PluginManager Bindings/LuaState Bindings/WebPlugin Bindings/Bindings Bindings/ManualBindings Bindings/LuaWindow Bindings/Plugin Bindings/PluginLua Bindings/WebPlugin)
+ add_library(Bindings
+ Bindings/Bindings
+ Bindings/LuaChunkStay
+ Bindings/LuaState
+ Bindings/LuaWindow
+ Bindings/ManualBindings
+ Bindings/Plugin
+ Bindings/PluginLua
+ Bindings/PluginManager
+ Bindings/WebPlugin
+ Bindings/WebPlugin
+ )
target_link_libraries(Bindings lua sqlite tolualib)